Vissza   Szerver Fórum > Szerver > Webszerver > Microsoft IIS

Microsoft IIS IIS 6.0, 7.0 és 8.0, ASP.NET

Válaszol
 
Téma eszközök Megjelenítési módok

IIS7, PHP FastCGI módban nem indul
  #1  
Régi 2009-07-27, 22:58
Gery logója
Gery Gery nem elérhető
Tag
 
Csatlakozott: 09-02-28
Hely: Kecskemét
Összes hozzászólás: 27
Gery elindult a közkedveltség útján
Alapbeállítás IIS7, PHP FastCGI módban nem indul

Manuálisan installáltam PHP-t IIS7-en:
  • kicsomagoltam a választott PHP csomagot: PHP 5.3 (5.3.0) VC9 x86 Non Thread Safe
  • Megcsináltam PATH változó hozzáadást
  • Kész a “Handler Mappings” beállítás:
    Idézet:
    Request path: *.php
    Module: FastCgiModule
    Executable: "C:\[Path to your PHP installation]\php-cgi.exe"
    Name: PHP via FastCGI
  • Parancssorból működik a php -info parancs, szép hosszú kimenete van

Valójában ezt a leírást követtem.

Mégis, a phptest.php script nem működik.
Nincs valami ötleted?
Válaszol idézettel

  #2  
Régi 2009-07-28, 07:12
Kefe logója
Kefe Kefe nem elérhető
ENTER gomb nyomó
 
Csatlakozott: 09-02-27
Hely: Budapest
Összes hozzászólás: 157
Kefe elindult a közkedveltség útján
Alapbeállítás

Ellenőrizd, hogy a Handler Mappings beállításokat a legfelső szinten (ahol a szerver neve is látható) végezted-e.

Kattints mondjuk a default website-ra, (vagy amelyik website-ra) és ellenőrizd, hogy a Handler Mappings örökölte-e a legfelső szintű beállításokat, látszik-e a *.php sor FastCGI módban.
__________________
---
Saját SEO szkriptek: Camelpark SEO centrum
Válaszol idézettel

  #3  
Régi 2009-07-28, 09:19
Gery logója
Gery Gery nem elérhető
Tag
 
Csatlakozott: 09-02-28
Hely: Kecskemét
Összes hozzászólás: 27
Gery elindult a közkedveltség útján
Alapbeállítás

Leellenőriztem, ez rendben van, nem Handler Mappings setup lehet a gond.
Válaszol idézettel

  #4  
Régi 2009-07-28, 12:26
Keller logója
Keller Keller nem elérhető
Tag
 
Csatlakozott: 09-02-28
Hely: Budapest
Összes hozzászólás: 37
Keller elindult a közkedveltség útján
Alapbeállítás

Egy kollégám nemrégiben futott bele hasonlóba, a Default timezone beállítás segített neki...

A php.ini-ben add meg a Default timezone = Europe/Budapest értéket.
Több info: http://us.php.net/manual/en/timezones.europe.php

Nem logikus hibamegoldás, de segíthet, ha 500-as hibára fut a php.
Válaszol idézettel
Válaszol

Címkék
fastcgi, iis7, php

Téma eszközök
Megjelenítési módok

Hozzászólás szabályai
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is bekapcsolva
Pofik bekapcsolva
Az [IMG] kód bekapcsolva
A HTML kód kikapcsolva

Fórum ugrás



A pontos idő 20:11 , a GMT +2 időzóna szerint.


Szerver hardver támogatónk Tárhely: Real.Com-94 hoszting
Powered by vBulletin®, Copyright © 2000 - 2019, Jelsoft Enterprises Ltd.